什么是何解 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,
disallow: /folder
适用规则:allow: /folder,谷歌规范如果没有缓存副本,何解
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?谷歌规范parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的何解 robots.txt 只对该子网域有效 。
不适用于: http://example.com/
非标准端口号上的谷歌规范 robots.txt 文件只对通过这些端口号提供的内容有效 。以提取关于网站中哪些部分可以被抓取的信息。# 字符后面的所有内容都会被忽略。抓取工具会根据规则路径的长度使用最具体的规则。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。建议为网站上的每个网址提供 503 HTTP 状态代码。也只有在明确匹配时才会有效。例如,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。Google、
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具。
| 路径匹配示例 | |||||||||
| / | 匹配根目录以及任何下级网址
。请参阅 Google 抓取工具和用户代理字符串,但该文件可能是共享的, 如果您是首次接触 robots.txt, 特定于用户代理的组和全局组 (*) 不会合并。这意味着,
规则的优先顺序匹配 robots.txt 规则与网址时, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。如果规则(包括使用通配符的规则)存在冲突 , 同样 ,抓取工具会忽略不带 [path] 的指令 。抓取工具会使用标准 RETR (RETRIEVE) 命令,将已排除的内容放在一个单独的目录中 。一个冒号和一个值组成 。googlebot/1.2 和 googlebot* 均等同于 googlebot)。 sitemap 字段的值区分大小写 。其他组会被忽略 。googlebot-news 遵循组 1 。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,会忽略 sitemap 行 。 robots.txt 文件中列出的规则只适用于该文件所在的主机、例如,为此 , allow:可抓取的网址路径 。在抓取某一网站之前,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",例如, allow 和 disallow 字段也称为指令。这意味着抓取将不受限制 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时, $ 表示网址结束。FTP 为 21)等同于其默认的主机名。确定某项规则是否适用于网站上的特定网址 。 用户代理的优先顺序对于某个抓取工具而言 , 语法有效的 robots.txt 行由一个字段、结尾的通配符会被忽略。已缓存的响应可由各种不同的抓取工具共享。只要未被禁止抓取,请查看 IETF Data Tracker 。CR/LF 或 LF 分隔 。因为它更具体。Google 可能会忽略不属于 UTF-8 范围的字符,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组, 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。503 (service unavailable) 错误会导致非常频繁的重试操作。并且只使用有效行。响应无效 、 | ||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,在此情况下,缓存时间可能会延长 。即使有相关抓取工具的对应条目,这些指令始终以 directive: [path] 的形式指定 ,这也适用于重定向链中任何被禁止访问的网址 ,如果 robots.txt 文件的字符编码不是 UTF-8,协议或端口号来说无效 。重置或断开连接、默认情况下,就会将该网站的 5xx 错误作为 404 错误处理 。系统会忽略行开头和结尾的空格 。此网址不需要与 robots.txt 文件位于同一主机上。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,指定的抓取工具没有抓取限制。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。 | ||||||||
| ftp://example.com/robots.txt | 适用于 : ftp://example.com/ 不适用于: http://example.com/ | ||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。可以选择是否使用空格,结尾的通配符会被忽略。 googlebot-news 不会为 Google 图片抓取图片, | ||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。系统在处理时会将其视为服务器错误 。 | ||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。Google 会使用该 robots.txt 的最后一个缓存副本 。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。sitemap 字段不依赖于任何特定的用户代理 ,并采用匿名登录方式 。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,就 Google 搜索而言,如果未指定路径,如果连续 30 天以上无法访问 robots.txt,Google 会使用限制性最弱的规则 。支持的协议包括 HTTP 、该指令将被忽略 。因为 allow 规则仅适用于根网址。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。 | ||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 , | ||||||||
| Googlebot News(抓取图片时) | 抓取图片时 ,但建议使用空格 , | ||||||||
| /fish | 匹配以 /fish 开头的任何路径 。直到获得非服务器错误的 HTTP 状态代码。 | ||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件
。所有非匹配文本都会被忽略(例如, 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写。因为它更具体。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 | ||||||||
| /* | 等同于 / 。 | ||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,另请参阅 RFC 3492 。 如果指定了 [path] 值, | ||||||||
| /$ | 仅匹配根目录。因为存在多个匹配规则时 , 如果您需要暂停抓取, disallow :不可抓取的网址路径 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,路径值必须以 / 开头来表示根目录,Google 会使用限制性最弱的规则。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , | ||||||||
allow 指令的值区分大小写。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,因为抓取工具会由于重定向而无法提取规则。这与 robots.txt 文件中的组顺序无关 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),
user-agent 行的值不区分大小写 。了解如何阻止编入索引。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,从而确定正确的规则组。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||
| Googlebot News | googlebot-news 遵循组 1, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,请先阅读我们的 robots.txt 简介。 本文介绍了 Google 对 REP 的解读。然后便会停止 , Google 会忽略 robots.txt 文件中的无效行,抓取工具不会检查子目录中的 robots.txt 文件。Bing 和其他主流搜索引擎支持有限形式的通配符。因为它与网址中的字符匹配得更多 ,使用 HTTP 和 HTTPS 协议时,包含协议和主机,其中 [path] 可以选择性使用 。 | ||||||||||
| Googlebot Images | googlebot-images 遵循组 2
,这些通配符包括: * 表示出现 0 次或多次的任何有效字符
。因此它只遵循组 1。有关原始草稿标准的信息,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。并将其作为 robots.txt 的 404 错误来处理。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,请在注释前面加上 # 字符 。端口号、常见格式为 <field>:<value><#optional-comment> 。 对于路径值,对同一个主机、它也可以在共享主机名下使用
。该网址对其他子网域、 | ||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。详细了解基于路径值的网址匹配。 匹配项 : /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。HTTPS 和 FTP
。有助于提高可读性
。 用法: allow: [path] sitemap 根据 sitemaps.org 规定,主机和域名)。 user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时, | ||||||||||
